Theory & Practical Classes Lectures

DNS Configuration in Cisco Packet Tracer

not found

We are going to configure the DNS server but before configuring the DNS server; we have to create the network topology.

We will take two Routers and each Router need to have two networks and both the Router will be connected with the Serial DCE cable which will create another network.

In the first Router Fa0/0 port; we have some computers.

In the first Router Fa0/1 port; we have connected the DNS server.

In the second Router Fa0/0 port; we have the Facebook server and in the second Router Fa0/1 port; the Google server is connected to it.

The IP Addresses that we are going to assign for the topology are as follow:

First Router Fa0/0 port is assigned with IP Address 1.0.0.1 that is connected to a switch and the switch will have some computers under same networking addresses.

First Router Fa0/1 port is assigned with IP Address 8.0.0.1 and it is connected to the DNS server; DNS server will be assigned with IP Address of 8.8.8.8.

First Router Se0/0/0 port is assigned with IP Address of 5.0.0.1; DCE cable one end is connected to this port.

Second Router Fa0/0 port is assigned with IP Address 10.0.0.1 and it is connected to the Facebook server; Facebook server will be assigned with the IP Address of 10.10.10.10.

Second Router Fa0/1 port is assigned with IP Address 20.0.0.1 and it is connected to the Google server; Google server will be assigned with the IP Address of 20.20.20.20.

Second Router Se0/0/0 port is assigned with IP Address of 5.0.0.2; DCE cable other end is connected to this port.

Now we also need to configure the DNS server by mapping the IP Addresses of Facebook server 10.10.10.10 and Google server 20.20.20.20 with its associated domain names that are facebook.com for 10.10.10.10 Facebook server and google.com for 20.20.20.20 Google server.

We know that it is quite difficult to remember the IP Addresses for the users so we prefer to use domain names instead of remembering those IP Addresses; therefore if user type facebook.com in the browser then the request will moves to DNS server and DNS server will search its associated IP Address from the database that is 10.10.10.10 for the domain name facebook.com then DNS server will respond to the user client system and let user system know the IP Address 10.10.10.10; so that now client system can directly access the Facebook server with the IP Address 10.10.10.10.

Therefore this is how the DNS server plays its vital role to manage all domains to facilities the user to access the servers without remembering their IP Address.

Now let us follow the steps to configure the topology along with the DNS server.

We are going to configure first Router

Continue with configuration dialog? [yes/no]: no

Router>enable

Router#configure terminal

Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 1.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 8.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#interface serial 0/0/0
Router(config-if)#ip address 5.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#clock rate 64000
Router(config-if)#exit

Router(config)#exit

Router#write

Building configuration...
[OK]

Router#show ip route

C 1.0.0.0/8 is directly connected, FastEthernet0/0
C 8.0.0.0/8 is directly connected, FastEthernet0/1
C 5.0.0.0/8 is directly connected, Serial0/0/0

Router#exit

Router>

Let us configure the second Router;

Continue with configuration dialog? [yes/no]: no

Router>enable

Router#configure terminal

Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#interface fastEthernet 0/1
Router(config-if)#ip address 20.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#interface serial 0/0/0
Router(config-if)#ip address 5.0.0.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#exit

Router#write

Building configuration...
[OK]

Router#show ip route

C 10.0.0.0/8 is directly connected, FastEthernet0/0
C 20.0.0.0/8 is directly connected, FastEthernet0/1
C 5.0.0.0/8 is directly connected, Serial0/0/0

Now we will apply the Router RIP protocol to the first Router; so that it can identify the second Router and it can recognize all IP Addresses of the adjacent Routers.

Router>enable

Router#configure terminal

Router(config)#router rip

Router(config-router)#network 1.0.0.1
Router(config-router)#network 8.0.0.1
Router(config-router)#network 10.0.0.1
Router(config-router)#network 20.0.0.1
Router(config-router)#network 5.0.0.1
Router(config-router)#network 5.0.0.2
Router(config-router)#exit

Router(config)#exit

Router#write

Building configuration...
[OK]

Router#exit

Router>

Now we will apply the Router RIP protocol to the second Router; so that it can identify the first Router and it can recognize all IP Addresses of the adjacent Routers.

Router>enable

Router#configure terminal

Router(config)#router rip

Router(config-router)#network 1.0.0.1
Router(config-router)#network 8.0.0.1
Router(config-router)#network 10.0.0.1
Router(config-router)#network 20.0.0.1
Router(config-router)#network 5.0.0.1
Router(config-router)#network 5.0.0.2
Router(config-router)#exit

Router(config)#exit

Router#write

Building configuration...
[OK]

Router#exit

Router>

Now to map the domain names with the IP Addresses; we have to open the DNS server desktop; select the DNS option from the list of options then we need to select on option for the DNS service and we have to write the unique domain names in the name field and IP Address of the Facebook and Google server in the address field; before closing the DNS server window; we need to click the save option to save the records in the DNS server database pull.

We can also modify the pages of Facebook Server and Google server from the HTTP options; so that both the server pages look different from one and another.

Now our DNS server is ready; so we can check the process from the client computers which is connected through the Router ports Fa0/0.

Open browser and type facebook.com and google.com once at a time; press enter; now we will observe that the home page will appear of Facebook server or Google server; which one the user tries to access.

DNS Configuration in Cisco Packet Tracer Working of DNS in Computer Networks What is DNS Server in Networking What is DNS Server What is DNS in Computer Network What is DNS How to Configure DNS Server in Cisco Packet Tracer PDF How to Configure DNS Server in Cisco Packet Tracer How to Configure DNS Server How DNS Works Step By Step How DNS Server Works DNS Server Not Responding DNS Server Configuration Step By Step DNS Server Configuration in Cisco Router DNS Server Configuration in Cisco Packet Tracer Working of DNS in Computer Networks What is DNS Server in Networking What is DNS Server What is DNS in Computer Network What is DNS How to Configure DNS Server in Cisco Packet Tracer PDF How to Configure DNS Server in Cisco Packet Tracer How to Configure DNS Server How DNS Works Step By Step How DNS Server Works DNS Server Not Responding DNS Server Configuration Step By Step DNS Server Configuration in Cisco Router DNS Server Configuration in Cisco Packet Tracer Working of DNS in Computer Networks What is DNS Server in Networking What is DNS Server What is DNS in Computer Network What is DNS How to Configure DNS Server in Cisco Packet Tracer PDF How to Configure DNS Server in Cisco Packet Tracer How to Configure DNS Server How DNS Works Step By Step How DNS Server Works DNS Server Not Responding DNS Server Configuration Step By Step DNS Server Configuration in Cisco Router DNS Server Configuration in Cisco Packet Tracer DNS Configuration in Cisco Packet Tracer

Free Tutorial of Web Development

HTML, CSS, Java Script, PHP & MySQL

Free Tutorial of Web Design

HTML, CSS, Java Script

24 Important Interview Questions

Frequently Ask in Interview Panel

Online Competitive Mock Test

Open Book Examination